Supported Browsers

To use our Web application, you'll need a browser from the following list:

Browser Version
Microsoft Internet
Explorer
9, 10 (payers may need to update settings to support TLS 1.2)
11+
Google Chrome Latest version
Mozilla Firefox Latest version
Safari 7+
Mobile Android Latest version
Mobile Chrome Latest version
Mobile Firefox Latest version
Mobile Safari Latest version

If you receive a "This page can’t be displayed" error similar to what is shown here, your browser does not support TLS 1.2. You will need to enable TLS by going to "Internet Options" in your browser and enabling the TLS protocols, if available, or upgrade to a supported browser.

page can't be displayed

First Time Visitors